Incoming Email Delayed

Incident Report for Keeping

Resolved

Starting at approximately 5:05 AM Eastern Daylight Time, our primary email backbone provider, MailGun, experienced an issue with the domain where we receive inbound emails on our customer's behalf. They resolved the issue at approximately 10:05 Eastern Daylight Time.
Posted Mar 13, 2025 - 11:02 EDT

Monitoring

MailGun has resolved the issues and emails should be flowing again. We are monitoring the fix.
Posted Mar 13, 2025 - 10:12 EDT

Update

The issue has been identified - we are waiting for MailGun to resolve the issue. Only mailboxes connected via forwarding are affected.
Posted Mar 13, 2025 - 09:13 EDT

Identified

MailGun is not accepting email to incoming.keeping.com. We are working with MailGun to resolve the issue.
Posted Mar 13, 2025 - 08:22 EDT

Investigating

We are investigating an issue with our email backbone provider, MailGun. Incoming email is delayed.
Posted Mar 13, 2025 - 07:52 EDT
This incident affected: Chrome Extension and Keeping App.