Intermittent App Slowdowns

Incident Report for Keeping

Identified

We've identified the issue and are working with Google Cloud Platform to resolve. Some users may experience slowdowns or intermittent errors when accessing the app.
Posted Sep 24, 2026 - 15:18 EDT

Investigating

We are seeing occasional slowdowns of the app, possibly related to upstream issues with our GCP hosted load balancer. We are investigating.
Posted Sep 24, 2026 - 11:19 EDT
This incident affects: Keeping App.