Slow sync and website loading

Incident Report for Keeping

Resolved

This incident has been resolved - please contact support@keeping.com if you are still experiencing issues.
Posted Nov 10, 2025 - 13:31 EST

Monitoring

A fix has been implemented and we are monitoring the results. Thanks for your patience here!
Posted Nov 10, 2025 - 12:52 EST

Investigating

We're still seeing slowdowns in app performance and are continuing to investigate.
Posted Nov 10, 2025 - 11:23 EST

Update

We're still seeing slowdowns in app performance and are continuing to investigate
Posted Nov 10, 2025 - 11:08 EST

Monitoring

We've identified an issue that caused a slowdown in website performance and ticket syncing. The issue has been resolved and we are monitoring the system as it recovers.
Posted Nov 10, 2025 - 10:54 EST
This incident affected: Chrome Extension and Keeping App.