This issue appears resolved - please restart your Chrome Browser if you are still experiencing issues, or reach out to support@keeping.com.
Posted Nov 18, 2025 - 10:33 EST
Update
We've implemented a workaround which should restore service for most users. Full recovery is ongoing as Cloudflare continues to remediate on their end.
Posted Nov 18, 2025 - 09:45 EST
Update
Cloudflare is continuing to remediate the issue and we are investigating workarounds. Service remains intermittent based on your geographic location.
Posted Nov 18, 2025 - 09:31 EST
Update
We are continuing to monitor and investigate workarounds.
Posted Nov 18, 2025 - 08:50 EST
Update
Cloudflare is still resolving the issue and service remains intermittent. We are investigating workarounds. https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 08:14 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 07:26 EST
Monitoring
Cloudflare appears to have resolved the issue, we are continuing to monitor.
Posted Nov 18, 2025 - 07:18 EST
Investigating
We are investigating issues with Cloudflare, our global DNS provider.
Posted Nov 18, 2025 - 06:58 EST
This incident affected: Chrome Extension and Keeping App.