Intermittent connection issues

Incident Report for Keeping

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 17:48 EDT

Update

GCP is still resolving the root cause but all Keeping systems are fully operational and we are continuing to monitor.
Posted Sep 01, 2026 - 13:05 EDT

Update

Google Cloud Platform experienced a major outage starting at 10:44 EDT. Keeping is hosted on Google Cloud Platform, so our services were affected. Remediation is in affect and service is being restored.

https://status.cloud.google.com/incidents/J5ia5t9p3g9Q5Wi7r8Ev
Posted Sep 01, 2026 - 12:15 EDT

Monitoring

A system wide Google Cloud is affecting Keeping - we're monitoring as the system recovers.
Posted Sep 01, 2026 - 12:02 EDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 11:33 EDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 11:31 EDT

Investigating

We are currently investigating this issue.
Posted Sep 01, 2026 - 11:31 EDT
This incident affected: Chrome Extension and Keeping App.