Performance Issues with Gmail Sidebar

Incident Report for Keeping

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 11:34 EDT

Monitoring

A fix has been implemented and we are now monitoring.
Posted Jul 31, 2025 - 11:19 EDT

Investigating

We are currently investigating performance issues with the Keeping Sidebar.
Posted Jul 31, 2025 - 11:02 EDT
This incident affected: Chrome Extension and Keeping App.