Google has fixed the issue, and services are beginning to return to normal. We are continuing to monitor.
Posted Jun 12, 2025 - 16:24 EDT
Update
Google has identified the root cause and is rolling out a fix. We are still experiencing issues with email syncing and login - we'll post another update as the situation develops.
Posted Jun 12, 2025 - 15:51 EDT
Identified
Due to a widespread Google Cloud outage, parts of Keeping are temporarily down. We're monitoring closely and will be back to normal as soon as it's resolved. Thank you for your patience!
Posted Jun 12, 2025 - 14:47 EDT
Investigating
We are investigating issues with signing into the main Keeping application.
Posted Jun 12, 2025 - 14:40 EDT
This incident affected: Chrome Extension and Keeping App.